Were upgrading jquery from v1.11.3 to v3.4.1 and were getting buildFragment error using canjs version 2.2.5

We have a huge application built on canjs with more than 250 screens

Current jQuery Version: v1.11.3
Need to upgrade JQuery to: v3.4.1
Our current canjs version: 2.2.5
Our current steal version: 0.11.4

  1. Which version of canjs has fix for $buildFragment
    according to this post https://github.com/canjs/canjs/pull/2177 buildFragment is fixed in this version we belive, but currently still yields the error after upgrading to 2.3.28

  2. Which canjs version is the best compatible version for jquery latest version of v3.4.1 which also has the smallest migration path.

Thanks in advance

Hi @smoothlikejazz, can you give more details about what the problem is?

It would be great if you can post a CodePen (or any simplified example) with the issue.

@cherif_b It is our mistake. We upgraded canjs to 2.3.28 but we were loading 2.2.5 version of can/util/jquery/jquery.js and it was giving $.buildFragment error.
We loaded the 2.3.28 of can/util/jquery/jquery.js and it worked.

canjs 2.3.28 is directly compatible with jquery 3.4.1 without making any changes to application.

Awesome! We are glad that it worked for you!
Thank you for your feedback.