Error Starting donejs develop

Any idea what causes this error?

thecountofzero@Link ~/Sites/donejs-chat
’ > donejs develop’

donejs-chat@0.0.0 develop /Users/thecountofzero/Sites/donejs-chat
done-serve --develop --port 8080

sh: done-serve: command not found

npm ERR! Darwin 15.2.0
npm ERR! argv “/Users/thecountofzero/.nvm/versions/node/v5.8.0/bin/node” “/Users/thecountofzero/.nvm/versions/node/v5.8.0/bin/npm” “run” "develop"
npm ERR! node v5.8.0
npm ERR! npm v3.8.1
npm ERR! file sh
npm ERR! errno ENOENT
npm ERR! syscall spawn
npm ERR! donejs-chat@0.0.0 develop: done-serve --develop --port 8080
npm ERR! spawn ENOENT
npm ERR!
npm ERR! Failed at the donejs-chat@0.0.0 develop script ‘done-serve --develop --port 8080’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the donejs-chat package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! done-serve --develop --port 8080
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs donejs-chat
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls donejs-chat
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /Users/thecountofzero/Sites/donejs-chat/npm-debug.log
Error: Command npm did not complete successfully
at ChildProcess. (/Users/thecountofzero/Sites/donejs-chat/node_modules/donejs-cli/lib/utils.js:37:23)
at emitTwo (events.js:100:13)
at ChildProcess.emit (events.js:185:7)
at Process.ChildProcess._handle.onexit (internal/child_process.js:204:12)

Never mind. Missing done-serve.

Hey @thecountofzero, you are using DoneJS 0.8.0-pre, this is a prerelease and hasn’t been verified yet, just to let you know. You might do better sticking with DoneJS 0.7.x for now. donejs -V will tell you what you have.

If you do:

npm install -g donejs

It should give you 0.7.2.

Although if you want to test 0.8-pre out that would be great to! File any issues you encounter.

Yep, getting the same error on OSX while following the quickstart guide.

npm ERR! Darwin 15.3.0
npm ERR! argv "/usr/local/Cellar/node/5.8.0/bin/node" "/usr/local/bin/npm" "run" "develop"
npm ERR! node v5.8.0
npm ERR! npm  v3.7.3
npm ERR! file sh
npm ERR! errno ENOENT
npm ERR! syscall spawn
npm ERR! elevate@0.0.0 develop: `done-serve --develop --port 8080`
npm ERR! spawn ENOENT

└── donejs@0.7.2

Per @thecountofzero suggestion, recommend updating the quickstart guide to install done-serve.
npm install -g done-serve

What version of donejs-cli does it say you have? I’m going to run it myself to verify.

@jwogrady I think it may be because I published a new version of our generators on Friday and you are getting that rather than the 0.7.0 version. I just published a new version so running donejs init donejs-chat should get you the correct versions of everything now… Running it myself to verify.

I can confirm the problem is with npm installing the prerelease generator-donejs. I’m rerunning to see if my publish fixed it.

Cool, so the additional Quick Start step will not be needed after the patch? Can confirm manually installing done-serve solved my issue.

done-serve is new to donejs 0.8.0 (which is in prerelease), the step in the guide won’t be needed because it will be installed automatically. My mistake caused your app to be generated expecting done-serve instead of can-serve.

So anyways, thanks for trying the prerelease :slight_smile: Be sure to report any bugs you find.

Tests are showing the guide to be passing now,

No worries. I just uninstalled donejs and done-serve and installed again per the tut.

projects $ npm install -g donejs


/usr/local/bin/donejs -> /usr/local/lib/node_modules/donejs/bin/donejs

└─┬ donejs@0.7.2
  ├─┬ commander@2.9.0
  │ └── graceful-readlink@1.0.1
  ├─┬ cross-spawn-async@2.1.9
  │ ├─┬ lru-cache@4.0.0
  │ │ ├── pseudomap@1.0.2
  │ │ └── yallist@2.0.0
  │ └─┬ which@1.2.4
  │   ├─┬ is-absolute@0.1.7
  │   │ └── is-relative@0.1.3
  │   └── isexe@1.1.2
  └── q@1.4.1

Looks like I have the correct version now. Thanks!

Looks like I have 0.7.0

npm ls --depth=0 -g 18:50
├── done-serve@0.1.1
├── donejs@0.7.2
└── npm@3.8.1