Problems with latest NW.js

I have having trouble getting my donejs app to work with a newer version of NW.js than the recommended 0.12.3.

Formerly I was running my old JavascriptMVC as a Chrome packaged app using many of the chrome.* platform APIs. As of NW.js version 0.13 there is full support for chrome platform APIs which is actually perfect for me. The problem is that when building with anything higher than 0.12.3, several nwjs processes are run, but no window is launched. I have tried clearing the AppData to see if that was the issue, but it is still not working. I have also tried with every version up to 0.20.1 (latest stable) with the same results.

Looking at the migration guide from 0.12 to 0.13, I don’t see anything that jumps out at me that would cause a problem. Maybe something to do with app:// and file:// urls changing to chrome-extension://, but grepping through the stealjs-nw and donejs-nw code I can’t find anything that would be affected by this.

Can anyone provide some insight?

Got it working. The first thing I did was update nw-builder in steal-nw to the latest version 3.1.3, but that didn’t fix the issue. I found that package.json was using string values for width and height in the window property. Changing to integer values fixes it.

1 Like